杭电1074(交作业+状态压缩)

Doing Homework(难度:1)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math

思路:

题意:有n门课,每门课s还有d天要交作业,需要c天做完,晚交一天扣1分,求怎样排列做作业的顺序能使得扣分最少。

方法:状态压缩DP。

AC代码:

#include <iostream>
#include <cstring>
#include <stack>
using namespace std;

#define INF 0xfffffff

struct hw{
    string name;//课程名称 
    int ddl;//截止日期 
    int cost;//花费时间 
}work[20];

struct state{
    int cost;//花费时间 
    int redu;//扣的分数 
    int pre;//上一个状态 
    int cur;//当前状态写的哪门作业 
}dp[1<<15+1]; //n最大为15  

int main()
{
    int t,n,smax;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(dp,0,sizeof(dp));//初始化
        for(int i=0;i<n;i++)
        {
            cin>>work[i].name>>work[i].ddl>>work[i].cost;
        }
        smax=1<<n;
        for(int i=1;i<smax;i++)//枚举所有可能的情况 
        {
            dp[i].redu=INF;//初始化 
            for(int j=n-1;j>=0;j--)//找前一步状态中写的是哪门作业 
            {
                int tmp=1<<j;//第几门作业  
                if(i&tmp)//找到i所对应哪个状态 
                {
                    int pre=i-tmp;//前一个状态 
                    int reduce=dp[pre].cost+work[j].cost-work[j].ddl;//当前扣掉的分数 
                    if(reduce<0) reduce=0;//若扣了负分,则相当于没有扣分 
                    if(reduce+dp[pre].redu<dp[i].redu)//递推 
                    {
                        dp[i].redu=reduce+dp[pre].redu;//更新扣掉的分数 
                        dp[i].pre=pre;//更新前一个状态是pre
                        dp[i].cur=j;//更新目前写的作业是j 
                        dp[i].cost=dp[pre].cost+work[j].cost;//更新消耗的时间 
                    }
                } 
            }
        }
        //1<<n-1相当于所有作业全写一遍 
        //相当于输出写完所有作业时被扣的分,即题目的要求 
        cout<<dp[smax-1].redu<<endl;
        stack<int>q;
        int tmp=smax-1;
        while(tmp)
        {
            q.push(dp[tmp].cur);//将课程压入栈 
            tmp=dp[tmp].pre;
        }
        while(!q.empty())
        {
            cout<<work[q.top()].name<<endl;//依次取栈顶 
            q.pop();
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值