POJ 3723(最大生成树+kuruakal)

Conscription

Time Limit: 1000MS
Memory Limit: 65536K

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

思路:

题意:组建一支军队,包括n个女孩m个男孩,每雇佣一个人需要花费10000元。若女孩x和男孩y有d关系,那么可以花费10000雇佣了x就可以花费10000-d来雇佣y。每个人只能使用一次关系。给出女孩和男孩的 r 组关系,求最少的花费。

解决:

  • 女孩编号为1 … n,男孩编号为1+m … n+m
  • 将每一对有关系的女孩和男孩放在一个集合里,共有 p 个集合,即共 p 对节点,也即 p 条边(p个男孩、p个女孩)
  • 每条边的权值为雇佣男孩的费用,雇佣女孩的费用为10000
  • 求他们的最小生成树,和相加,再加上p * 10000

方法1:最大生成树,ans=(n+m)*10000 - 最大生成树(森林)

方法2:最小生成树,每条边权值为10000-d

方法1AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

#define maxn 50010
#define INF 0x3f3f3f3f 
int t,n,m,r;//t样例n女m男r组关系 
int x,y,d;//x与y有d关系 
int ans,cnt;
int f[maxn];//父亲节点 

struct node{
    int x;
    int y;
    int d;
}people[maxn];

int cmp(node a,node b)
{
    return a.d>b.d;
}

void init()
{
    for(int i=1;i<maxn;i++)
    {
        f[i]=i;
    }
}

void add(int x,int y,int d)
{
    people[cnt].x=x;
    people[cnt].y=y;
    people[cnt].d=d;
    cnt++;
}

int find(int x)
{
    if(x!=f[x]) f[x]=find(f[x]);
    return f[x];
}

int kruskal()
{
    sort(people,people+cnt,cmp);
    for(int i=0;i<cnt;i++)
    {
        int fx=find(people[i].x);
        int fy=find(people[i].y);
        if(fx!=fy)
        {
            f[fy]=fx;
            ans-=people[i].d;
        }
    }
}

int main()
{
    cin>>t;
    while(t--)
    {
        cnt=0;
        init();
        cin>>n>>m>>r;//n女m男r组关系 
        while(r--)
        {
            cin>>x>>y>>d;//x与y有关系d
            add(x,y+n,d);
        }
        ans=(n+m)*10000;
        kruskal();
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值