UVA-1225 Digit Counting

Vjudge题目链接,水题,题目怎么说就怎么写。

1e4 就算是 n 2 n^2 n2也能过,何况根本到不了 n 2 n^2 n2

Sample Input
2
3
13

Sample Output
0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int cnt[10];

int main(){
    int n;
    cin>>n;
    while(n--){
        int x;
        cin>>x;
        memset(cnt, 0, sizeof(cnt));
        for(int i = 1; i <= x; i++){
            int tmp = i;
            while(tmp > 0){
                cnt[tmp%10]++;
                tmp/=10;
            }
        }
        for(int i = 0; i < 10; i++){
            printf("%d", cnt[i]);
            if(i != 9)printf(" ");
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值