POJ - 1979(深搜与广搜)

4 篇文章 0 订阅
1 篇文章 0 订阅

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13

这题深搜和广搜都可以,属于基础题。深搜要注意不符条件的返回,广搜要注意一个点可能多次入队(因为在访问时才设置成visit=1,入队时未设置,因为数据量小就没管了)。

#include<cstdio>
#include<iostream>
#include<sstream>
#include<set>
#include<stack>
#include<map>
#include<queue>
#include<vector>
#include<list>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 25;
int visit[maxn][maxn];
char pic[maxn][maxn];
int m, n, ans= 0;


void dfs(int i, int j){
    if(i < 0 || i >= n || j < 0 || j >= m)return;//越界
    if(visit[i][j] > 0 || pic[i][j] == '#')return;//已访问 或 不可访问
    visit[i][j] = 1;//标记访问
    ans++;
    dfs(i-1, j);
    dfs(i+1, j);
    dfs(i, j-1);
    dfs(i, j+1);
}

struct node{
    int x, y;
    node(int x, int y): x(x), y(y) {}
};

bool in_range(node a){
    if(a.x < 0 || a.x >= n || a.y < 0 || a.y >= m)return false;
    if(visit[a.x][a.y] > 0)return false;
    if(pic[a.x][a.y] == '#')return false;
    return true;
}

void bfs(node init){
    queue<node> q;
    q.push(init);
    while(!q.empty()){
        node u = q.front(); q.pop();
        if(visit[u.x][u.y] == 0)visit[u.x][u.y] = 1, ans++;
        if(in_range(node(u.x-1, u.y)))q.push(node(u.x-1, u.y));
        if(in_range(node(u.x+1, u.y)))q.push(node(u.x+1, u.y));
        if(in_range(node(u.x, u.y-1)))q.push(node(u.x, u.y-1));
        if(in_range(node(u.x, u.y+1)))q.push(node(u.x, u.y+1));
    }
    return;
}


int main(){
    //freopen("input.txt", "r", stdin);
    while(~scanf("%d %d", &m, &n)){
        if(m == 0 && n == 0)break;
        int ini_i, ini_j;
        memset(visit, 0, sizeof(visit)); ans = 0;
        for(int i = 0; i < n; i++)scanf("%s", pic[i]);
        for(int i = 0; i < n; i++){
            for(int j = 0; j < m; j++){
                if(pic[i][j] =='@')ini_i = i, ini_j = j;
            }
        }
        //for(int i = 0; i < n; i++)printf("%s\n", pic[i]);
        //dfs(ini_i, ini_j);

        bfs(node(ini_i, ini_j));
        /*
        for(int i = 0; i < n; i++){
            for(int j = 0; j < m; j++){
                printf("%d", visit[i][j]);
            }
            printf("\n");
        }
        */
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值