划分树(求区间第k小值)

F - Kth number
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Give you a sequence and ask you the kth big number of a inteval.
 

Input

The first line is the number of the test cases. 
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere. 
The second line contains n integers, describe the sequence. 
Each of following m lines contains three integers s, t, k. 
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
 

Output

For each test case, output m lines. Each line contains the kth big number.
 

Sample Input

      
      
1 10 1 1 4 2 3 5 6 7 8 9 0 1 3 2
 

Sample Output

      
      
2
 

............................................................................此题我有疑问...................................................................

为甚么我输出区间第k小值才能A,而题目问的是第K大的值

/*

划分树模板
求区间的第k大值,或者求给定区间的第k小值
*/


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;


const int MAXN=100010;
int tree[30][MAXN];                     //表示划分后每个位置的值,tree[0][1..n]第零层表示输入的原始数据,输入数据不变
int sorted[MAXN];                       //sort排序后的输入数据
int toleft[30][MAXN];                   //toleft[p][i]表示第i层从1到i有多少个数分入左边


void build(int l,int r,int dep)         //建树,build(1, n, 0);
{
    if(l==r)return;                      //到达树的叶子节点
    int mid=(l+r)>>1;                       //中间位置
    int same=mid-l+1;                       //表示等于中间值而且被分入左边的个数***????????????***
    for(int i=l;i<=r;i++)
      if(tree[dep][i]<sorted[mid])
         same--;
    int lpos=l;                             //划分后的左侧开始位置
    int rpos=mid+1;                         //右侧开始位置
    for(int i=l;i<=r;i++)                   //遍历整个数组,进行左右划分
    {
        if(tree[dep][i]<sorted[mid])                    //比中间的数小,分入左边
             tree[dep+1][lpos++]=tree[dep][i];
        else if(tree[dep][i]==sorted[mid]&&same>0)              //?????????????????
        {
            tree[dep+1][lpos++]=tree[dep][i];
            same--;
        }
        else                                            //比中间值大分入右边
            tree[dep+1][rpos++]=tree[dep][i];
        toleft[dep][i] = toleft[dep][l-1] + lpos - l;         //从1到i放左边的个数
    }
    build(l,mid,dep+1);                     //对左划分子树递归建树
    build(mid+1,r,dep+1);                   //对优化分子树递归建树
}




/*
*
* 查询区间第k小的数,[L,R]是大区间,[l,r]是要查询的小区间
*
*/
int query(int L,int R,int l,int r,int dep,int k)
{
    if(l==r)return tree[dep][l];                  //查找到结果
    int mid = (L+R)>>1;                              //划分区间,找中值
    int cnt = toleft[dep][r]-toleft[dep][l-1];        //[l,r]中位于左边的个数
    if(cnt >= k)                                //要查询的数在左区间
    {
        int newl=L+toleft[dep][l-1]-toleft[dep][L-1];           //L+要查询的区间前被放在左边的个数    ????????
        int newr=newl+cnt-1;                                //左端点加上查询区间会被放在左边的个数    ????????
        return query(L,mid,newl,newr,dep+1,k);
    }
    else
    {
         int newr=r+toleft[dep][R]-toleft[dep][r];              //??????????
         int newl=newr-(r-l-cnt);                               //??????????
         return query(mid+1,R,newl,newr,dep+1,k-cnt);
    }
}




int main()
{
    freopen("b:\\data.in.txt", "r", stdin);
    int T;
    int n,m;
    int s,t,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(tree,0,sizeof(tree));
        for(int i=1;i<=n;i++)           //从1开始
        {
            scanf("%d",&tree[0][i]);
            sorted[i]=tree[0][i];
        }
        sort(sorted+1,sorted+n+1);
        build(1,n,0);               //建树,初始化build(1,n,0)
        while(m--)
        {
            scanf("%d%d%d",&s,&t,&k);
            printf("%d\n",query(1,n,s,t,0,k));
        }
//        printf("排序的数组为:\n");
//        for(int i = 1; i <= 10; i++)
//            cout << sorted[i] << " ";
//        cout << endl << endl;
//        for(int i = 0; i < 6; i++)
//        {
//            printf("第%d层:\n", i);
//            for(int j = 1; j <= 10; j++)
//                cout << tree[i][j] << " ";
//            cout << endl << endl;
//        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值