PTA 7-42 圆形体体积计算器 (20分)

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

球体体积 V=
​3

​4
​​ πr
​3
​​ ,其中r是球体半径。
圆柱体体积 V=πr
​2
​​ h,其中r是底圆半径,h是高。
圆锥体体积 V=
​3

​1
​​ πr
​2
​​ h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
然后从标准输入读进一个整数指令。

输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。

输入样例:
1
2
3
2.4 3
0
输出样例:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

#include<stdio.h>
#include<math.h>

int main(void)
{
    int num;
    double result, r, h;
    double PI =atan(1)*4;
    int flag = 0;
    while(1)
    {
        printf("1-Ball\n2-Cylinder\n3-Cone\nother-Exit\n");
        printf("Please enter your command:\n");
        scanf("%d", &num);
        switch(num)
        {
            case 1:
                printf("Please enter the radius:\n");
                scanf("%lf", &r);
                result = 4 * PI * r * r * r / 3;
                break;
            case 2:
                printf("Please enter the radius and the height:\n");
                scanf("%lf %lf", &r, &h);
                result = PI * r * r * h;
                break;
            case 3:
                printf("Please enter the radius and the height:\n");
                scanf("%lf %lf", &r, &h);
                result = PI * r * r * h / 3;
                break;
            default:
                flag = 1;
                break;
        }
        if(flag)
            break;
        else
            printf("%.2lf\n", result);
    }
    return 0;
}
  • 7
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值