板子题poj2407 欧拉函数 Java实现

提起欧拉函数我们先从一道问题说起

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:这道问题就是简单欧拉函数的板子题,就是给定你一个数判断他的欧拉函数、下面我们来说一说欧拉函数

定义:在数论中,对于一个正整数n,欧拉函数是小于n的正整数中与n互质的数的数目(φ(1)=1)

通式:φ(x)=x(1-1/p1)(1-1/p2)(1-1/p3)……(1-1/pn)

其中p1,p2……pn为x的所有质因数,x是不为0的整数但是每种质因数只有一种例如,φ(12)=2*2*3,φ(12)=12*(1-1/2)*(1-1/3)=4;

欧拉函数是一个积性函数——若m,n互质φ(mn)=φ(m)φ(n)

特殊积性:当n为奇数时φ(m)=φ(n)。(以上资料来自百度百科)

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			int n = sc.nextInt();
			if (n == 0)
				break;
			System.out.println(eular(n));

		}
	}

	static int eular(int n) {
		int ans = 1, i;
		for (i = 2; i * i <= n; i++)
			if (n % i == 0) {
				n /= i;
				ans *= (i - 1);
				while (n % i == 0) {
					n /= i;
					ans *= i;
				}
			}
		if (n > 1)
			ans *= (n - 1);
		return ans;
	}
}

代码实现本题:

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值