HDU-2803

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
Input Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed. Output For each test case, output the biggest value of F you can find on a line. Sample Input
2
1 2
0
Sample Output
4017
  • 题意:给一个公式,给一组数字,求出公式的最大值。思路:这里很明显就是找到给出的一些列数字中的最大值,分配给它最多的数字,其它的数字全部乘1即可。
  • AC Code
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    long long a[110];
    int main()
    {
        int N;
        while(~scanf("%d",&N) && N)
        {
            for(int i=0;i<N;++i)
            {
                scanf("%lld",&a[i]);
            }
            sort(a,a+N);
            long long res=0;
            for(int i=0;i<N-1;++i) 
    		{
    			res = res + a[i]; 
    		}         
            res = res + a[N-1]*(2009-N+1);
            printf("%lld\n",res);
            
        }
        return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值