实验11-2-2 学生成绩链表处理(20 分)
本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。
函数接口定义:
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
函数createlist
利用scanf
从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:
struct stud_node {
int num; /*学号*/
char name[20]; /*姓名*/
int score; /*成绩*/
struct stud_node *next; /*指向下个结点的指针*/
};
输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。
函数deletelist
从以head
为头指针的链表中删除成绩低于min_score
的学生,并返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct stud_node {
int num;
char name[20];
int score;
struct stud_node *next;
};
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
int main()
{
int min_score;
struct stud_node *p, *head = NULL;
head = createlist();
scanf("%d", &min_score);
head = deletelist(head, min_score);
for ( p = head; p != NULL; p = p->next )
printf("%d %s %d\n", p->num, p->name, p->score);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80
输出样例:
2 wang 80
4 zhao 85
struct stud_node *head, *tail, *p;
p = (struct stud_node *)malloc( sizeof(struct stud_node));
head = tail = NULL;
scanf("%d", &p->num);
while (p ->num != 0){
if (head == NULL){
head = tail = p;
}
else {
tail = p;
scanf("%s%d", p->name, &p->score);
p = (struct stud_node *)malloc(sizeof(struct stud_node));
tail -> next = p;
scanf("%d", &p->num);
}
}
if (tail != NULL)
tail -> next = NULL;
free(p);
return head;
}
struct stud_node *deletelist( struct stud_node *head, int min_score ){
struct stud_node *p, *pre;
while ( head && head->score < min_score)
head = head->next;
if (head == NULL)
return NULL;
pre = head;
p = head->next;
while (p){
if (p->score < min_score){
pre->next = p->next;
p = p->next;
}
else {
pre = p;
p = p->next;
}
}
return head;
}
红色:防止段错误,
蓝色:不要漏了
绿色:链表中不包括最后一个值