03-树2 List Leavess (25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

思路:用结构数组构造树,再用层序遍历的方法输出叶子节点

#include<stdio.h>

#include<malloc.h>

#define Null -1

#define MAXSIZE 11


typedef int Tree;

typedef struct QueueNode* Queue;

struct TreeNode{

    Tree left;

    Tree right;

};

struct QueueNode{

    int Data[MAXSIZE];

    int front;

    int rear;

};

struct TreeNode T[MAXSIZE];

int check[MAXSIZE] = {0};

void AddQueue(Queue Q,int a){

    Q->rear = (Q->rear + 1)%MAXSIZE;

    Q->Data[Q->rear] = a;

}

int DeleteQueue(Queue Q){

    int A;

    A = Q->Data[Q->front + 1];

    Q->front = (Q->front + 1)%MAXSIZE;

    return A;

}

int IsEmptyQueue(Queue Q){

    return Q->front == Q->rear;

}

int BuildTree(struct TreeNode[]);

void LevelOrder(Tree root);


int main(){

    Tree root;

    root = BuildTree(T);

    LevelOrder(root);

    return 0;

}


int BuildTree(struct TreeNode[]){

    int N;

    int i;

    scanf("%d",&N);

    int root = Null;

    char cleft, cright;

    if(N){

        for ( i = 0; i < N; i++){

            getchar();

            scanf("%c %c",&cleft, &cright);

            if(cleft != '-'){

                T[i].left = cleft - '0';

                check[T[i].left] = 1;

            }

            else T[i].left = Null;

            if (cright != '-'){

                T[i].right = cright - '0';

                check[T[i].right] = 1;

            }

            else T[i].right = Null;

        }

        for ( i = 0; i < N; i++){

            if(check[i] == 0)

                break;

        }

        root = i;

    }

    return root;

}

void LevelOrder(Tree root){

    Queue Q;

    int i;

    int flag = 0;

    if (root == Null) return;

    Q = (Queue)malloc(sizeof(struct QueueNode));

    Q->front = Q->rear = 0;

    AddQueue(Q,root);

    while (!IsEmptyQueue(Q)){

        i = DeleteQueue(Q);

        if (T[i].left != Null)

            AddQueue(Q,T[i].left);

        if (T[i].right != Null)

            AddQueue(Q,T[i].right);

        if (T[i].left == Null && T[i].right == Null){

            if (flag){

                printf(" ");

            }

            flag = 1;

            printf("%d",i);

        }

    }

}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值