分数化小数(decimal)

输入正整数 a b c ,输出 a / b 的小数形式,精确到小数点后 c 位。 a b ≤10 6 c ≤100 。 输
入包含多组数据,结束标记为
a b c 0
样例输入:
1 6 4
0 0 0
样例输出:

Case 1: 0.1667

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
    int a,b,c;
    while(cin>>a>>b>>c){
        int zhengshu=a/b;
        printf("%d.",zhengshu);
        a=a%b;
        for(int i=0;i<c;i++){
            if(i==c-1){
                int temp=a*10/b;
                int rest=a*10%b;
                int temp2=rest*10/b;
                if(temp2>=5)
                    temp++;
                printf("%d\n",temp);
                break;
            }
            a=a*10;
            printf("%d",a/b);
            a=a%b;
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值