Pop Sequence

02-线性结构4 Pop Sequence(25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M(the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
作者: 陈越
单位: 浙江大学
时间限制: 400ms
内存限制: 64MB

这道题考查就是一个入栈出栈的顺序,比较简单。我的代码借助了两个栈,写起来也比较简单。

#include<iostream>
#include<stack>
#include<cstring>
int s[1005];
using namespace std;
int main() {
    int m,n,k;
    while(cin>>m>>n>>k) {
        for(int i=0; i<k; i++) {
            stack<int>a,b;
            for(int j=n; j>0; j--) {
                b.push(j);
           //     cout<<b.top()<<endl;
            }
            memset(s,0,sizeof(s));
            for(int j=0; j<n; j++) {
                cin>>s[j];
            }
          //  cout<<"OK"<<endl;
            int c=0;
            bool flag=true;
            while(c<n) {
                if(b.size()>0&&b.top()==s[c]) {
                //    cout<<"pop: "<<b.top()<<endl;
                    b.pop();
                    c++;
                //    cout<<"c="<<c<<endl;

                } else if(b.size()>0&&b.top()<s[c]) {
                    if(a.size()<m-1) {
                        a.push(b.top());
                    //    cout<<"push a:"<<b.top()<<endl;
                        b.pop();
                    } else  {flag=false; break;}
                } else if(a.size()>0&&a.top()==s[c]) {
                 //   cout<<"pop: "<<a.top()<<endl;
                    a.pop();
                    c++;
                }
                else if(a.size()>0&&a.top()>s[c]) {
                   // cout<<"Sorry"<<endl;
                    flag=false;
                    break;
                }
            }
            if(flag==true)  cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
    return 0;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值