数据结构实验之链表三:链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Sample Input

12 56 4 6 55 15 33 62 -1

Sample Output

62 33 15 55 6 4 56 12

Hint

不得使用数组。

Source

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
}*head;

struct node *creat()
{
    struct node  *p;
    int x;
    head = (struct node*)malloc(sizeof(struct node));
    head -> next =  NULL;
    while(~scanf("%d", &x))
    {
        if(x==-1)break;
        else
        {
            p=(struct node *)malloc(sizeof(struct node));
            p->data=x;
            p->next=head->next;
            head->next=p;
        }
    }
    return head;
};

void show(struct node *head)
{
    struct node *t;
    t = head->next;
    while(t)
    {
        printf("%d%c", t->data, t->next==NULL?'\n': ' ');
        t = t->next;
    }
}
int main()
{


    head = creat();
    show(head);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值