数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>

struct  node
{
    int data;
    struct node *next;
}*head1, *head2, *head;
struct node *creat(int n)
{
    int i;
    struct node *t, *p, *head;
    head = (struct node*)malloc(sizeof(struct node));
    head -> next =NULL; t = head;
    for(i = 0; i < n; i++)
    {
        p = (struct node*)malloc(sizeof(struct node));
        scanf("%d", &p->data);p->next = NULL;
        t ->next = p;t = p;
    }
    return head;
};

void show(struct node *head)
{
    head=head->next;
    while(head)
    {
        if(head->next!=NULL)
            printf("%d ",head->data);
        else
            printf("%d\n",head->data);
        head=head->next;
    }
}
void change(struct node*head1, struct node *head2,struct node *head)
{
    struct node *p1, *p2, *t;
    p1 = head1->next; p2 = head2->next;
    t = head;
    while(p1&&p2)
    {
        if(p1==NULL||p2==NULL)
            break;
        else
        {
            if(p1->data<p2->data)
            {
                t->next=p1;
                t=p1;
                p1=p1->next;
            }
            else
            {
                t->next = p2;
                t = p2;
                p2 = p2 ->next;
            }
        }
    }
    if(p2==NULL)
        t->next=p1;
    else
        t->next=p2;
    show (head);
};

int main()
{
    head1 = (struct node*)malloc(sizeof(struct node));
    head2 = (struct node*)malloc(sizeof(struct node));
    head = (struct node*)malloc(sizeof(struct node));
    int m, n;
    scanf("%d%d", &m, &n);
    head1=creat(m);head2 = creat(n);
    change(head1 ,head2, head);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值