HDU 1710 Binary Tree Traversals

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
  
  
7 4 2 8 9 5 6 3 1
题目大意:
给出二叉树的前序,中序,求出二叉树的后序
首先要明白是什么二叉树,以及二叉树的前序,中序,后序分别是什么。
这里有两个写的比较详细的博客,可以作为了解:
关于二叉树:
http://blog.csdn.net/luckyxiaoqiang/article/details/7518888
关于前序中序得到后序
http://www.cnblogs.com/rain-lei/p/3576796.html
思路很容易想到,利用递归的思想,当遍历完左子树和右子树之后才输出根节点

代码如下:

#include<stdio.h>
int pre[1001],in[1001];
int flag;
//在给定的区间内寻找子树的根节点
int search(int value,int head,int tail)
{
    int i;
    for(i=head;i<=tail;i++)
    {
        if(in[i]==value)
        {
            return i;
        }
    }
    return -1; //在指定区间没找到返回-1
}

int branch(int head,int tail)
{
    int loca,value;
    loca=search(pre[flag],head,tail);
    value=pre[flag];
    if(loca==-1) //若返回-1说明子树为空
        return 0;
    flag++;
    branch(head,loca-1);//先遍历左子树
    branch(loca+1,tail);//再遍历右子树
    //最后输出根节点
    if(value!=pre[0])//后序遍历,根节点一定是在最后一个
        printf("%d ",value);
    else
        printf("%d",value);
    return 0;
}
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&pre[i]);
        for(i=0;i<n;i++)
            scanf("%d",&in[i]);
        flag=0;
        branch(0,n-1);
        printf("\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值