删数问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
键盘输入一个高精度的正整数n(≤100位),去掉其中任意s个数字后剩下的数字按照原来的左右次序组成一个新的正整数。编程对给定的n与s,寻找一种方案,使得剩下的数字组成的新数最小。
Input
输入有多组 每组包括原始数n,要去掉的数字数s;
Output
输出去掉s个数后最小的数
Sample Input
178543 4
Sample Output
13
#include <bits/stdc++.h>
using namespace std;
int main()
{
int k, s, len;
char a[101];
while(cin>>a>>s)
{
while(s--)
{
len=strlen(a);
k=0;
while ( k<len && a[k]<=a[k+1] )
k++;
while ( k<len )
{
a[k]=a[k+1];
k++;
}
}
len = strlen(a);
k=0;
while(k<len&&a[k]=='0')
k++;
if(k<len)
{
while(k<len)
{
cout<<a[k];
k++;
}
}
else
cout<<"0"<<endl;
cout<<endl;
}
return 0;
}