数据结构实验之链表二:逆序建立链表
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
Input
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
Output
依次输出单链表所存放的数据。
Sample Input
10
11 3 5 27 9 12 43 16 84 22
Sample Output
22 84 16 43 12 9 27 5 3 11
Hint
不能使用数组!
Source
#include <iostream>
using namespace std;
struct node
{
int data;
struct node *next;
};
node *create(int n)
{
node *head,*p;
head = new node;
head->next = NULL;
while(n--)
{
p = new node;
cin>>p->data;
p->next = head->next;
head->next = p;
}
return head;
}
void print(node *head)
{
node *p;
p = head->next;
while(p)
{
cout<<p->data;
if(p->next!=NULL)
cout<<' ';
p = p->next;
}
cout<<endl;
}
int main()
{
int n;
node *h;
cin>>n;
h = create(n);
print(h);
return 0;
}
qwq