数据结构实验之二叉树二:遍历二叉树
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。
Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output
每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。
Sample Input
abc,,de,g,,f,,,
Sample Output
cbegdfa
cgefdba
Hint
Source
xam
#include <bits/stdc++.h>
using namespace std;
struct bitree
{
char data;
struct bitree *lc;
struct bitree *rc;
};
char str[51];
int i;
bitree *create()
{
bitree *tree;
if(str[++i]==',')
tree =NULL;
else
{
tree = new bitree;
tree->data = str[i];
tree->lc = create();
tree->rc = create();
}
return tree;
}
void iorder(bitree *tree)
{
if(tree)
{
iorder(tree->lc);
cout<<tree->data;
iorder(tree->rc);
}
}
void porder(bitree *tree)
{
if(tree)
{
porder(tree->lc);
porder(tree->rc);
cout<<tree->data;
}
}
int main()
{
bitree *tree;
while(cin>>str)
{
i = -1;
tree = create();
iorder(tree);
cout<<endl;
porder(tree);
cout<<endl;
}
return 0;
}