【杭电】2017 字符串统计(字符串有毒!)

36 篇文章 0 订阅
20 篇文章 0 订阅

字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 68924    Accepted Submission(s): 37846


Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
 

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 

Sample Input
  
  
2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf
 

Sample Output
  
  
6 9
这题主要涉及gets()的应用界限吧,挺重要的。
#include<stdio.h>//字符串统计
#include<string.h>
int main()
{
    int n;
    char str[100];
    while(EOF!=scanf("%d",&n))
    {
        getchar();
        while(n--)//依次读取字符串
        {    
            int count=0,i=0;
            gets(str);
            while(str[i]!='\0')
            {
                if(str[i]>='0'&&str[i]<='9')//计算数字字符个数
                    count++;
                i++;
            }
            printf("%d\n",count);
        }
    }
    return 0;
}
或者是
#include<stdio.h>//字符串统计
#include<string.h>
int main()
{
    int n;
    char str[100];
    while(EOF!=scanf("%d%*c",&n))
    {
        while(n--)//依次读取字符串
        {    
            int count=0,i=0;
            gets(str);
            while(str[i]!='\0')
            {
                if(str[i]>='0'&&str[i]<='9')//计算数字字符个数
                    count++;
                i++;
            }
            printf("%d\n",count);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值