【POJ】1003_Hangover宿醉

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We’re assuming that cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + … + 1/(n+1) card lengths, where the top card overhangs the second by 1/2, the second overhangs the third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n+1). This is illustrated in the figure below.

你可以用一摞卡片在桌子上悬挂多远?如果你有一张卡片,你可以创建一个半个卡片长度的最大悬挂。(我们假设卡片必须垂直于桌子。)用两张卡片你可以用顶端的卡片在底端的半个卡片长度开始悬挂,并且底端的卡片可以悬挂在桌子的三分之一卡片长度处,总共的最大悬挂长度是1/2 + 1/3 = 5/6 卡片长度。一般地,你可以用n张卡片悬挂1/2 + 1/3 + 1/4 + … + 1/(n+1)的卡片长度,顶部卡片悬挂第二张卡片的1/2处,第二张卡片悬挂第三张的1/3处,第三张悬挂第四章的1/4处,以此类推,最后底部的卡片悬挂在桌子的1/(n+1)处。如下图所示。
在这里插入图片描述

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

输入包含一个或多个测试数据,最后一行包含数字0.00,代表输入的结束信号。每个测试数据是一行包含一个正的浮点数c,它的值最小是0.01,最大是5.20, c将包含正好三位数。

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

对于每一个测试样例,输出能够达到至少卡片悬挂长度的最小卡片数。使用样例中的精确输出格式。

Sample input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

MyCode

# include<iostream>
using namespace std;

double digit(int n)
{
    return 1.0/n;
}

int main(void)
{
    double test, sum=0;
    cin>>test;
    while(test!=0.00){
        for(int i=2; i<100000; i++)
        {
            sum = sum+digit(i);
            if(sum>=test){
                cout<<i-1<<" card(s)"<<endl;
                break;
            }
        }
        //cout<<sum<<endl;
        sum=0;
        cin>>test;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值