POJ2251 Dungeon Master(三维BFS)

题面:

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

 

Input:

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

 

Output:

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!

 

 Sample Input:

3 4 5

S....

.###.

.##..

###.#

#####

 

#####

##.##

##...

#####

 

#####

#.###

####E

 

1 3 3

S##

#E#

###

0 0 0

 

Sample Output:

Escaped in 11 minute(s).

Trapped!

 

分析:

三维BFS,讲真三维这个东西乍一听很吓人的好吗!我承认我第一次在题解标题里看到这几个字就先怂为敬,先做其他题了。但是做完了简单题没得做了,又回到这道题的时候发现,好吧也没有我想的那么难。三维主要就是增加了往上和往下这两个方向,加上四联通方向,一共可以进行六个方向的移动,地图当然也得用三维数组来存了,不同层数中间间隔开的空白行用getchar()接一下,不然会像我一样一不小心就把地图搞混乱了。其实只是个三维BFS的裸题。

 

AC代码:

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int maxn = 40;
int L, R, C, ans;
char maze[maxn][maxn][maxn];
bool book[maxn][maxn][maxn];
int dis[maxn][maxn][maxn];
int dir[6][3] = {{0, 0, 1}, {0, 1, 0}, {0, 0, -1}, {0, -1, 0}, {-1, 0, 0}, {1, 0, 0}};

struct node{
	int r, c, lev;
};

bool law(int dlev, int dr, int dc){
	if(dr >= R || dr < 0 || dc >= C || dc < 0 || dlev >= L || dlev < 0 || 
		book[dlev][dr][dc]) return false;
	return true;
}

void BFS(int br, int bc, int blev){
	queue<node>q;
	node front;
	front.r = br;front.c = bc;front.lev = blev;
	q.push(front);
	dis[front.lev][front.r][front.c] = 0;
	book[front.lev][front.r][front.c] = true;
	while(!q.empty()){
		front = q.front();
		q.pop();
		for(int i = 0; i < 6; i++){
			node next;
			next.lev = front.lev + dir[i][0];
			next.r = front.r + dir[i][1];
			next.c = front.c + dir[i][2];
			if(law(next.lev, next.r, next.c)){
				if(maze[next.lev][next.r][next.c] == '.'){
					book[next.lev][next.r][next.c] = true;
					dis[next.lev][next.r][next.c] = dis[front.lev][front.r][front.c] + 1;
					q.push(next);
				}
				else if (maze[next.lev][next.r][next.c] == 'E'){
					book[next.lev][next.r][next.c] = true;
					ans = dis[front.lev][front.r][front.c] + 1;
					return;
				}
				
			}
		}
	}
	
}

int main(){	
	while(cin>>L>>R>>C){
		if(L == 0 && R == 0 && C == 0) break;
		int br, bc, bl;
		
		memset(book, 0, sizeof(book));
		memset(dis, -1, sizeof(dis));
		ans = -1;
		for(int i = 0; i < L; i++){
			for(int j = 0; j < R; j++) scanf("%s", &maze[i][j]);
			getchar();
		}
		
		for(int i = 0; i < L; i++){
			for(int j = 0; j < R; j++){
				for(int k = 0; k < C; k++) {
					if(maze[i][j][k] == 'S'){
						bl = i; br = j; bc = k;
					}
				}
			}
		}
		
		BFS(br, bc, bl);
		
		if(ans == -1) cout<<"Trapped!"<<endl;
		else cout<<"Escaped in "<<ans<<" minute(s)."<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值