00-自测4 Have Fun with Numbers (20)

00-自测4. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

提交代码

/*Having fun with numbers*/
#include <iostream>
#include <cstring>

int r_digit[20],ch_digit[20];

void to_Digit(char ch[],int n);
void double_num(int n);
int check_num(char ch[],int n);

using namespace std;
int main(){
	char ch[20];
	gets(ch);
	int len=strlen(ch),i;
	if(check_num(ch,len)){ 
		cout<<"Yes"<<endl;
	}//检查数字是否符合要求
	else{
		cout<<"No"<<endl;
	}
	for(i=0;i<len;++i){
		if(r_digit[i]<0){
			r_digit[i]+=10;
		}
		cout<<r_digit[i];
	}
	cout<<endl;
	return 0;
}

void to_Digit(char ch[],int n){
	int i;
	for(i=0;i<n;++i){
		ch_digit[i]=ch[i]-'0';
	}
}

void double_num(int n){
	int i;
	for(i=0;i<n;++i){
		r_digit[i]=ch_digit[i]*2;
	}
	for(i=n-1;i>0;--i){				//从低位到高位存储进位和本位
		r_digit[i-1]+=r_digit[i]/10;
		r_digit[i]=r_digit[i]%10;
	}
}

int check_num(char ch[],int n){
	int i,j;
	to_Digit(ch,n);   //转成数字
	double_num(n);	//将数字加倍
	for(i=0;i<n;i++)
		for(j=0;j<n;j++){
			if(ch_digit[i]==r_digit[j]){
				r_digit[j]-=10;		//便于区别(已经判定相等过的)
				break;
			}
		}
	for(i=0;i<n;i++)
		if(r_digit[i]>=0) return 0;		
	return 1;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值