蓝桥杯 算法训练 字符统计 Java

资源限制

内存限制:256.0MB   C/C++时间限制:1.0s   Java时间限制:3.0s   Python时间限制:5.0s

问题描述

  编写一个程序,不断输入字符直到遇到’#’为止。然后输出读入的空格’ ’,换行符’\n’和其它字符个数。(注:最后的‘#’不计入其他字符)

样例输入

Chapter 1. Getting Ready
Chapter 2. Introducing C
Chapter 3. #

样例输出

8 2 51

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String str = "";
		int space = 0;
		int n = 0; 
		int other = 0;

		while (true) {
			String input = sc.nextLine();
			if (input.endsWith("#")) {
				str += input.substring(0, input.length() - 1);
				n--;
				break;
			} else {
				str += input;
				n++;
			}
		}

		for (char ch : str.toCharArray()) {
			if (ch == ' ') {
				space++;
			} else if (ch != '#') { 
				other++;
			}
		}

		sc.close();
		n += 1;
		System.out.print(space + " " + n + " " + other);
	}
}

  • 28
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值