POJ-1182 食物链(带权并查集)

食物链
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 86400 Accepted: 25862

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 
有人用两种说法对这N个动物所构成的食物链关系进行描述: 
第一种说法是"1 X Y",表示X和Y是同类。 
第二种说法是"2 X Y",表示X吃Y。 
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 
1) 当前的话与前面的某些真的话冲突,就是假话; 
2) 当前的话中X或Y比N大,就是假话; 
3) 当前的话表示X吃X,就是假话。 
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 

Input

第一行是两个整数N和K,以一个空格分隔。 
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 
若D=1,则表示X和Y是同类。 
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3


一、原题地址

    传送门

二、大致题意

    中文题


三、思路

   大佬博客传送门

四、代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
using namespace std;
const int inf = 0x3f3f3f3f;
#define LL long long int 
long long  gcd(long long  a, long long  b) { return a == 0 ? b : gcd(b % a, a); }



int n, k;
int father[10];
int ans;
struct Node
{
	int pa, rel;
	void init(int x)
	{
		p[x].pa = x;
		p[x].rel = 0;
	}
}p[50005];
int find(int x)
{
	if (p[x].pa == x)
		return x;
	else
	{
		int t = p[x].pa;
		p[x].pa = find(p[x].pa);
		p[x].rel = (p[x].rel + p[t].rel) % 3;
		return p[x].pa;
	}
}
void join(int x, int y, int d)
{
	int fx = find(x), fy = find(y);
	if (fx != fy)
	{
		p[fx].pa = fy;
		p[fx].rel = (-(3 + d - 1) - p[x].rel + p[y].rel) % 3;
	}
	else
	{
		if (d == 1 && p[x].rel != p[y].rel)
		{
			ans++;
		}
		if (d == 2 && (3 - p[x].rel + p[y].rel) % 3 != d - 1)
		{
			ans++;
		}
	}
}
int main()
{
	scanf("%d%d", &n, &k);
	ans = 0;
	for (int i = 1; i <= n; i++)
		p[i].init(i);
	while (k--)
	{
		int x, y, d;
		scanf("%d%d%d", &d, &x, &y);
		if (x > n || y > n)
		{
			ans++;
			continue;
		}
		if (d == 2 && x == y)
		{
			ans++;
			continue;
		}
		join(x, y, d);
	}
	printf("%d\n", ans);

	getchar();
	getchar();

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值