数据结构实验之链表四:有序链表的归并

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100

提示

不得使用数组!

 

 

 

#include <bits/stdc++.h>

using namespace std;

struct node
{
    int data;
    struct node *next;
};

int main()
{
    int n,m;
    struct node *head,*tail,*head1,*head2,*tail1,*tail2,*p,*q;
    head1=new node;
    head2=new node;
    head=new node;
    head->next=NULL;
    head1->next=NULL;
    head2->next=NULL;
    tail1=head1;
    cin>>n>>m;
    while(n--)
    {
        q=new node;
        cin>>q->data;
        q->next=NULL;
        tail1->next=q;
        tail1=q;
    }
    tail2=head2;
    while(m--)
    {
        p=new node;
        cin>>p->data;
        p->next=NULL;
        tail2->next=p;
        tail2=p;
    }
    p=head2->next;
    q=head1->next;
    tail=head;
    while(p&&q)
    {
        if(p->data<q->data)
        {
            tail->next=p;
            tail=p;
            p=p->next;
            tail->next=NULL;
        }
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
        }
        if(q)
        {
            tail->next=q;
        }
        if(p)
        {
            tail->next=p;
        }
    }
    p=head->next;
    while(p!=NULL)
    {
        cout<<p->data<<" ";
        p=p->next;
    }
    cout<<endl;
    return 0;
}
 


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值