题目描述:
实现一个栈,栈初始为空,支持四种操作:
1. push x – 向栈顶插入一个数 x;
2. pop – 从栈顶弹出一个数;
3. empty – 判断栈是否为空;
4. query – 查询栈顶元素。
现在要对栈进行 M 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。
输入格式:
第一行包含整数 M,表示操作次数。
接下来 M 行,每行包含一个操作命令,操作命令为push x、pop、empty、query 中的一种。
输出格式:
对于每个empty 和 query 操作都要输出一个查询结果,每个结果占一行。
其中,empty 操作的查询结果为YES 或NO ,query 操作的查询结果为一个整数,表示栈顶元素的值。
样例输入:
10 push 5 query push 6 pop query pop empty push 4 query empty
样例输出:
5 5 YES 4 NO
提示:
1≤M≤100000,
1≤x≤109
代码如下:
#include<bits/stdc++.h>
#define MAXN 100001
using namespace std;
long long a[MAXN],n,x,s=0;
string b;
int main(){
cin>>n;
while(n--){
cin>>b;
if(b=="push"){
cin>>x;
a[++s]=x;
}
else if(b=="pop"){
s--;
}
else if(b=="query"){
cout<<a[s]<<endl;
}
else{
if(!s){
cout<<"YES"<<endl;
}
else{
cout<<"NO"<<endl;
}
}
}
return 0;
}