Java sdut acm 1133 CC++经典程序训练3---模拟计算器

题目链接:点击打开链接

C/C++经典程序训练3---模拟计算器
Time Limit: 1000MS Memory Limit: 8192KB
Submit Statistic
Problem Description


简单计算器模拟:输入两个整数和一个运算符,输出运算结果。
Input


第一行输入两个整数,用空格分开;
第二行输入一个运算符(+、-、*、/)。
所有运算均为整数运算,保证除数不包含0。
Output


输出对两个数运算后的结果。
Example Input


30 50
*
Example Output


1500
Hint


Author


代码实现:

import java.util.Scanner;
class cul{
	int a;
	int b;
	public cul() {
		super();
	}
	public cul(int a, int b) {
		super();
		this.a = a;
		this.b = b;
	}
	public int calculate(char ope){
		if(ope == '+')
			return a+b;
		else if(ope == '-')
			return a-b;
		else if(ope == '*')
			return a*b;
		else if(ope == '/')
			return a/b;
		else
			return 0;
	}
}
public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		int a = input.nextInt();
		int b = input.nextInt();
		cul result = new cul(a,b);
		String ope1 = input.next();
		char ope = ope1.charAt(0);
		int s = result.calculate(ope);
		System.out.println(s);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值