K - Transformation

Yuanfang is puzzled with the question below: 
There are n integers, a 1, a 2, …, a n. The initial values of them are 0. There are four kinds of operations. 
Operation 1: Add c to each number between a x and a y inclusive. In other words, do transformation a k<---a k+c, k = x,x+1,…,y. 
Operation 2: Multiply c to each number between a x and a y inclusive. In other words, do transformation a k<---a k×c, k = x,x+1,…,y. 
Operation 3: Change the numbers between a x and a y to c, inclusive. In other words, do transformation a k<---c, k = x,x+1,…,y. 
Operation 4: Get the sum of p power among the numbers between a x and a y inclusive. In other words, get the result of a x p+a x+1 p+…+a y p. 
Yuanfang has no idea of how to do it. So he wants to ask you to help him. 

Input

There are no more than 10 test cases. 
For each case, the first line contains two numbers n and m, meaning that there are n integers and m operations. 1 <= n, m <= 100,000. 
Each the following m lines contains an operation. Operation 1 to 3 is in this format: "1 x y c" or "2 x y c" or "3 x y c". Operation 4 is in this format: "4 x y p". (1 <= x <= y <= n, 1 <= c <= 10,000, 1 <= p <= 3) 
The input ends with 0 0. 

Output

For each operation 4, output a single integer in one line representing the result. The answer may be quite large. You just need to calculate the remainder of the answer when divided by 10007.

Sample Input

5 5
3 3 5 7
1 2 4 4
4 1 5 2
2 2 5 8
4 3 5 3
0 0

Sample Output

307
7489

 

这题本来百思不得其解,后来看了某个大神的代码后惊为天人,flag表示这个子树是否都为同一个值

#include<bits/stdc++.h>

using namespace std;

int mod = 10007;
const int MAXN = 100000 + 10;
int a[4 * MAXN] , flag[4 * MAXN];

void Union(int k , int l , int r)
{
    if(!flag[l] || !flag[r])
        flag[k] = 0;
    else if(a[l] != a[r])
        flag[k] = 0;
    else
    {
        flag[k] = 1;
        a[k] = a[k << 1];
    }
}
void update(int rt ,int l , int r, int x , int y , int c ,int q)
{
    if(l >= x && r <= y && flag[rt])
    {
        if(q == 1)
            a[rt] = (a[rt] + c) % mod;
        else if(q == 2)
            a[rt] = (a[rt] * c % mod) % mod;
        else
            a[rt] = c;
        return;
    }
    if(flag[rt])
    {
        flag[rt << 1] = flag[rt << 1 | 1] = 1;
        a[rt << 1] = a[rt << 1 | 1] = a[rt];
        flag[rt] = 0;
    }
    int mid = (l + r) >> 1;
    if(mid >= x)
        update(rt << 1 , l , mid , x , y , c , q);
    if(mid < y)
        update(rt << 1 | 1 , mid + 1 , r , x , y , c , q);
    Union(rt , rt << 1 , rt << 1 | 1);
}

int query(int rt , int l , int r , int x , int y , int c)
{
    if(flag[rt] && l >= x && r <= y)
    {
        int ans = 1;
        for(int i = 1; i <= c ; i ++)
            ans = ( ans * a[rt] ) % mod;
        ans = (ans * (r - l + 1)) % mod;
        return ans;
    }
    if(flag[rt])
    {
        flag[rt << 1] = flag[rt << 1 | 1] = 1;
        flag[rt] = 0;
        a[rt << 1] = a[rt << 1 | 1] = a[rt];
    }
    int mid = (l + r) >> 1;
    int ans = 0;
    if(mid >= x)
        ans += query(rt << 1 , l , mid , x , y , c);
    if(mid < y)
        ans += query(rt << 1 | 1 , mid + 1 , r , x , y , c);
    return ans % mod;
}
int main()
{
    int n , m ;
    int q , x , y , c ;
    while(~scanf("%d %d" , &n , &m))
    {
        memset(flag , 1 , sizeof(flag));
        memset(a , 0 , sizeof(a));
        while(m --)
        {
            scanf("%d %d %d %d" , &q , &x , &y , &c);
            if(q <= 3)
                update(1 , 1 , n , x , y , c, q);
            else
                printf("%d\n" ,query( 1 , 1 , n , x , y , c));
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值