L - Vases and Flowers

  Alice is so popular that she can receive many flowers everyday. She has N vases numbered from 0 to N-1. When she receive some flowers, she will try to put them in the vases, one flower in one vase. She randomly choose the vase A and try to put a flower in the vase. If the there is no flower in the vase, she will put a flower in it, otherwise she skip this vase. And then she will try put in the vase A+1, A+2, ..., N-1, until there is no flower left or she has tried the vase N-1. The left flowers will be discarded. Of course, sometimes she will clean the vases. Because there are too many vases, she randomly choose to clean the vases numbered from A to B(A <= B). The flowers in the cleaned vases will be discarded.

Input

  The first line contains an integer T, indicating the number of test cases. 
  For each test case, the first line contains two integers N(1 < N < 50001) and M(1 < M < 50001). N is the number of vases, and M is the operations of Alice. Each of the next M lines contains three integers. The first integer of one line is K(1 or 2). If K is 1, then two integers A and F follow. It means Alice receive F flowers and try to put a flower in the vase A first. If K is 2, then two integers A and B follow. It means the owner would like to clean the vases numbered from A to B(A <= B).

Output

  For each operation of which K is 1, output the position of the vase in which Alice put the first flower and last one, separated by a blank. If she can not put any one, then output 'Can not put any one.'. For each operation of which K is 2, output the number of discarded flowers. 
   Output one blank line after each test case.

Sample Input

2
10 5
1 3 5
2 4 5
1 1 8
2 3 6
1 8 8
10 6
1 2 5
2 3 4
1 0 8
2 2 5
1 4 4
1 2 3

Sample Output

[pre]3 7
2
1 9
4
Can not put any one.

2 6
2
0 9
4
4 5
2 3

[/pre]

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int MAXN = 50000 + 10;
int QL, QR, L, R, n, m, x, ans;

struct f
{
    int sum;
    int lazy;
}tree[MAXN * 4];

void build(int left, int right, int rt)
{
    tree[rt].sum = 0, tree[rt].lazy = 1;
    if(left == right)
        return;
    int mid = (left + right) >> 1;
    build(left, mid, rt << 1);
    build(mid + 1, right, rt << 1 | 1);
}

void pushdown(int left, int right, int rt)
{
    int mid = (left + right) >> 1;
    tree[rt << 1].lazy = tree[rt << 1 | 1].lazy = 1;
    if(tree[rt].sum == right - left + 1)
    {
        tree[rt << 1].sum = mid - left + 1;
        tree[rt << 1 | 1].sum = right -mid;
    }
    else
        tree[rt << 1].sum = tree[rt << 1 | 1].sum = 0;
}

void put_flower(int left, int right, int rt)
{
    if(ans <= 0)
        return;
    if(L <= left && R >= right && tree[rt].lazy)
    {
        if(!tree[rt].sum)
        {
            ans -= (right - left + 1);
            tree[rt].sum = right - left + 1;
            if(QL < 0)
                QL = left - 1;
            QR = right - 1;
        }
        else
        {
            R += (right - left + 1);
            if(R > n)
                R = n;
        }
        return;
    }
    int mid = (left + right) >> 1;
    if(tree[rt].lazy)
        pushdown(left, right, rt);
    tree[rt].lazy = 0;
    if(L <= mid)
        put_flower(left, mid, rt << 1);
    if(R > mid)
        put_flower(mid + 1, right, rt << 1 | 1);
    tree[rt].sum = tree[rt << 1].sum + tree[rt << 1 | 1].sum;
    if(tree[rt].sum == right - left + 1 || !tree[rt].sum)
        tree[rt].lazy = 1;
}

void clearing(int left, int right, int rt)
{
    if(L <= left && R >= right)
    {
        ans += tree[rt].sum;
        tree[rt].lazy = 1;
        tree[rt].sum = 0;
        return;
    }
    if(tree[rt].lazy)
        pushdown(left, right, rt);
    tree[rt].lazy = 0;
    int mid = (left + right) >> 1;
    if(L <= mid)
        clearing(left, mid, rt << 1);
    if(R > mid)
        clearing(mid + 1, right, rt << 1 | 1);
    tree[rt].sum = tree[rt << 1].sum + tree[rt << 1 | 1].sum;
    if(tree[rt].sum == right - left + 1 || !tree[rt].sum)
        tree[rt].lazy = 1;
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        scanf("%d %d", &n, &m);
        build(1, n, 1);
        while(m --)
        {
            scanf("%d %d", &x, &L);
            L ++;
            if(x == 1)
            {
                scanf("%d", &ans);
                R = L + ans - 1;
                QL = QR = -1;
                put_flower(1, n, 1);
                if(QR >= 0)
                    printf("%d %d\n", QL, QR);
                else
                    printf("Can not put any one.\n");
            }
            else
            {
                scanf("%d", &R);
                R ++;
                ans = 0;
                clearing(1, n, 1);
                printf("%d\n", ans);
            }
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值