02-线性结构4 Pop Sequence

题目:
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
输入格式:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
输出格式:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
样例输入:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

样例输出:

YES
NO
NO
YES
NO

c语言实现:

#include<stdio.h>
#define MAX_SIZE  1024
int p = 1;  //入栈的值,本题中从1开始,故设初始值为1
int top = 1; //指明栈顶元素 stack[top-1]为栈顶元素
int stack[MAX_SIZE] = {0};		//栈
void push(){		
	stack[top++] = p++;
}
int pop(){	
	return stack[top--]; 
}
int isPopSeq(int a[],int m,int n){  //1为正确序列,0为错误的
	for(int i=0;i<n;i++){
		if(a[i] > stack[top-1]){
			while(stack[top-1] != a[i])
				push();
			if(top > m+1)	//该出栈序列所需栈大小大于给定栈大小则返回0
				return 0;
			pop();
		}
		else if(stack[top-1] == a[i])
			pop();
		else
			return 0;
	}
	return 1;
}
int main(){
	int m,n,k;
	scanf("%d%d%d",&m,&n,&k);
	int a[n];
	while(k--){
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		top = 1;
		p = 1;
		if(isPopSeq(a,m,n))
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

主要实现思路: 最初以为这题可以通过计算逆序数来实现,后来发现这样并不靠谱,于是选择了模拟出入栈过程来实现。将给定的出栈序列放在a数组中与栈中元素比对:
若a[i] > stack[top-1]: 将a[i]以前的数字全部压入栈中。如果压入栈中后栈中的数据大于栈的容量表明该序列不是正确出栈序列。
若a[i] == stack[top-1]:将栈顶元素出栈。
若a[i] < stack[top-1]:表明该出栈序列不是正确出栈序列。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

记与思

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值