[洛谷]P3146 [USACO16OPEN]248 (#区间dp)

84 篇文章 1 订阅
36 篇文章 0 订阅

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of NNpositive integers (2 \leq N\leq 2482≤N≤248), each in the range 1 \ldots 401…40. In one move, Bessie cantake two adjacent numbers with equal values and replace them a singlenumber of value one greater (e.g., she might replace two adjacent 7swith an 8). The goal is to maximize the value of the largest numberpresent in the sequence at the end of the game. Please help Bessiescore as highly as possible!

给定一个1*n的地图,在里面玩2048,每次可以合并相邻两个(数值范围1-40),问最大能合出多少。注意合并后的数值并非加倍而是+1,例如2与2合并后的数值为3。

输入输出格式

输入格式:

The first line of input contains NN, and the next NN lines give the sequence

of NN numbers at the start of the game.

输出格式:

Please output the largest integer Bessie can generate.

输入输出样例

输入样例#1

4
1
1
1
2

输出样例#1

3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.


思路

仍然是序列上的问题,考虑使用区间dp。相邻的2个数才能合并,合并后的数都是原数+1得到的。

所以,这道题和之前的区间dp一样,下一个状态是由较小区间(较小状态)得到的。

令dp[i][j]为在区间[i,j]中合并后的最大值。这里的合并指的是完全合并。那么就在区间[i,j]中继续枚举2个小区间,如果2个小区间相等,就可以合并。

dp[i][j]=max(dp[i][j],dp[i][k]+1) (dp[i][k]==dp[k+1][j])

为什么答案不是[1,n]呢?因为[1,n]不一定能合并,所以它可以为0。因此要记录答案。

#include <stdio.h>
#include <iostream>
using namespace std;
int n,m,s(0),a[257],dp[257][257];
signed main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	register int i,j,k,l;
	cin>>n;
	for(i=1;i<=n;i++)
	{
		cin>>dp[i][i];//不进行合并时价值就是自己 
		s=max(s,dp[i][i]);
	}
	for(l=2;l<=n;l++)//枚举区间长度 
	{
		for(i=1;i+l-1<=n;i++)//区间左端点 
		{
			j=i+l-1;//区间右端点 
			for(k=i;k<=j;k++)//枚举当前区间可以由哪两个小区间专一过来 
			{
				if(dp[i][k]==dp[k+1][j] && dp[i][k]!=0 && dp[k+1][j]!=0)
				{//如果2个区间相等就可以转移;如果2个区间等于0的话什么也合并不了 
					dp[i][j]=max(dp[i][j],dp[i][k]+1);
					s=max(s,dp[i][j]);
				}
			}
		}
	}
	cout<<s<<endl;
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值