POJ 1011 Sticks中的玄学问题

题目如下:

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

这道题的思路是从最小约数开始找起,每找到一个约数后,用深搜的方法判断小棒们是否能够组合成这个约数的长度。这道题的关键在于深度搜索的剪枝,不剪枝很容易出现超时错误。

  1.      以一个小棒为开头,用dfs看看能否把这个小棒拼凑成len长,如果可以,用vis[i]记录下用过的小棒,然后继续以另外一个小棒为开头,以此类推。
  2.       小棒的长度从大到小排序,这个就不解释了。
  3.       如果当前最长的小棒不能拼成len长,那么就返回前一步,更改前一步的最长小棒的组合情况(这里不能是全部退出),不用再继续搜索下去了。
  4.       最重要的,就是比如说17,9,9,9,9,8,8,5,2……如果当前最长小棒为17,它与第一个9组合之后dfs发现不能拼成len,那么17就不用和后面所有的9组合了,而直接和8开始组合。这个剪枝直接从TLE到16MS,很强大。

AC代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>

using namespace std;
int number,stick[65];
bool used[65];
bool result = false;
int length;

bool cmp(int a, int b)
{
    return a>b;
}

int find(int k,int culen)
{
    //cout<<number<<" %%% "<<k<<endl;
    while((used[k] || stick[k]+culen>length) && k<number ){k++;}
    return k;
}

void dfs(int culen, int p, int usen)
{
    //cout<<"culen: "<<culen<<" k: "<<k<<" usen: "<<usen<<endl;
    int k;
    if(result)return;
    //if(k>=number)return;
    //cout<<"k="<<k<<" and stick is"<<stick[k]<<endl;
    if(culen<length)
    {
        //while(stick[k]+culen>length && k<number){k = find(k+1);}
        if(culen!=0){k = find(p,culen);if(k>=number)return;}
        else {k = 0;while(used[k])k++;}

        used[k]=true;
        dfs(stick[k]+culen,k+1,usen+1);
        used[k]=false;
        if(culen==0)return;

        int ked = k;
        while(k<number){
            k = find(k+1,culen);
            if(k>=number)break;
            if(stick[k-1]==stick[k] && !used[k-1])continue;
            used[k] = true;
            dfs(stick[k]+culen,k+1,usen+1);
            ked = k;
            used[k]=false;
        }
        return;
    }

        if(culen==length){
        //cout<<"\tsuccess!"<<endl;
        if(usen == number){
            result = true;
            //cout<<"\tsuccess finally!"<<endl;
            return;
        }
        dfs(0,0,usen);
    }
    return;
}

int main()
{
    //int number;
    while(scanf("%d",&number) && number!=0){
        int sum=0;
        result = false;
        for(int i=0;i<number;i++)
        {
            scanf("%d",&stick[i]);
            sum+=stick[i];
            //if(maxstick<stick[i])maxstick=stick[i];
        }
        //int lo = 1;
        sort(stick,stick+number,cmp);
        //result = false;
        for(length=stick[0]; length<sum;length++)
        {
            if(sum%length==0){
                //length = i;
                memset(used, 0, sizeof(used));
                dfs(0,0,0);
                //cout<<"length="<<length<<endl;
                if(result)break;
            }

        }
        printf("%d\n",length);

    }
    return 0;
}

那么问题就来了, 上面的代码中主函数中的length变量是一个全局变量,在for循环里面它直接充当了控制变量,但是如果将这个for循环改成下面的样子就会出现WA。。

for(int i=stick[0]; i<sum;i++)
        {
            if(sum%i==0){
                length = i;
                memset(used, 0, sizeof(used));
                dfs(0,0,0);
                //cout<<"length="<<length<<endl;
                if(result)break;
            }

        }

真的特别迷...

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值