PAT A1025. PAT Ranking

1025. PAT Ranking (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

这一题开始有点棘手,参考算法笔记,看懂后其实挺简单的

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

//定义学生结构体 
struct Student{
	char id[15];         //准考证号 
	int score;			//分数 
	int location_number;//考场号 
	int local_rank;		//考场内排名 
}stu[30010];

//定义sort比较规则 
bool cmp(Student a,Student b){
	if(a.score != b.score){
		return a.score > b.score;//可以理解为a.score>b.score时,a放在b前面 
	}
	else{
		return strcmp(a.id,b.id) < 0;//分数相同比较准考证号大小,从小到大 
	}
} 

int main(){
	int n,k,num = 0;
	scanf("%d",&n);
	for(int i=1; i<=n; i++){
		scanf("%d",&k);
		//读入每个班成绩 
		for(int j=0; j<k; j++){
			scanf("%s %d",stu[num].id,&stu[num].score);//字符串不加& 
			stu[num].location_number = i;
			num++;
		}
		sort(stu + num - k,stu + num,cmp);//对该场考生排名
		stu[num-k].local_rank = 1;//该考场第一名在考场内排名第一
		//记录该考场剩余考生的local_rank
		for(int j=num-k+1; j<num ;j++){
			if(stu[j].score == stu[j-1].score){
				stu[j].local_rank = stu[j-1].local_rank;//分数相同,当场排名相同 
			}
			else{
				stu[j].local_rank = j+1-(num-k);//注意不要写是上一个排名+1,排名相同会跳过 
		 	} 
		} 

	}
	printf("%d\n",num);//输出总考生数
	sort(stu,stu+num,cmp);//全部考生排序
	int r = 1;
	for(int i=0; i<num; i++){
		if(i>0 && stu[i].score!= stu[i-1].score){
			r = i+1 ;//如果考生和上一个分数不同,更新r为人数加1 
		}
		printf("%s ",stu[i].id);
		printf("%d %d %d\n",r,stu[i].location_number,stu[i].local_rank); 
	} 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值