HD1000A + B Problem

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 339636 Accepted Submission(s): 106389

Problem Description

Calculate A + B.

Input

Each line will contain two integers A and B. Process to end of file.

Output

For each case, output A + B in one line.

Sample Input

1 1

Sample Output

2

杭电入门级水题,应该是大部分人在杭电做的第一道题吧,对于格式的掌握,也是从这里开始的,用三种方法:

 

c版本:

#include<stdio.h>
int main(){
    int a,b;
    while(scanf("%d%d",&a,&b )!=EOF)
    printf("%d\n",a+b);
}

c++版本:

#include<iostream>
using namespace std;
int main()
{
    int a,b;
    while(cin>>a>>b)
        cout<<a+b<<endl;
    return 0;
}

java版本:

import java.io.*;
import java.util.*;
class Main {                                           //一定要是Main
    public static void main(String[] args) {
        Scanner cin = new Scanner(new BufferedInputStream(System.in));
         int n,m;
        while(cin.hasNext())
        { 
             n = cin.nextInt();
             m = cin.nextInt();       
            System.out.println(n+m);
        }
    }
}

至与三种方法的大小,自己提交过后一比就知道了。

杭电刷题之路从这里开始….

转载于:https://www.cnblogs.com/LZYY/p/3306478.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值