问题描述
给定当前的时间,请用英文的读法将它读出来。
时间用时h和分m表示,在英文的读法中,读一个时间的方法是:
如果m为0,则将时读出来,然后加上“o’clock”,如3:00读作“three o’clock”。
如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。
时和分的读法使用的是英文数字的读法,其中0~20读作:
0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。
30读作thirty,40读作forty,50读作fifty。
对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。
按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。
输入格式
输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。
输出格式
输出时间时刻的英文。
样例输入
0 15
样例输出
zero fifteen
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
int i,j;
string a[20],b[4];
a[0]="zero";
a[1]="one";
a[2]="two";
a[3] ="three";
a[4]="four";
a[5]="five";
a[6]="six";
a[7]="seven";
a[8]="eight";
a[9]="nine";
a[10]="ten";
a[11]="eleven";
a[12]="twelve";
a[13]="thirteen";
a[14]="fourteen";
a[15]="fifteen";
a[16]="sixteen";
a[17]="seventeen";
a[18]="eighteen";
a[19]="nineteen";
b[0]="twenty";
b[1]="thirty";
b[2]="forty";
b[3]="fifty";
int n,m;
cin>>n>>m;
if(n<20)
cout<<a[n]<<" ";
else if(n==20)
{
cout<<b[0]<<" ";
}
else
{
cout<<b[0]<<" "<<a[n%10]<<" ";
}
if(m==0)
{
cout<<"o'clock";
}
else if((m!=0)&&(m<20))
{
cout<<a[m]<<endl;
}
else
{
if(m%10==0)
cout<<b[m/10-2]<<endl;
else
{
cout<<b[m/10-2]<<" "<<a[m%10]<<endl;
}
}
return 0;
}