Huffman codes

05-树9 Huffman Codes(30 分)

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2N63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (1000), then followed by M student submissions. Each student submission consists of Nlines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No

这个程序我花了不少时间,改改,找错误,放弃,重写。只能 说细节很多,感觉每个程序 都不是那么简单,需要自己 默默地付出许多。

#include<iostream>
#include<vector>
using namespace std;
#define maxsize 64
struct node{
int weight=-1;
node* l=NULL;
node* r=NULL;
};
using haffmantree=node;
vector<node> Minheap;
vector<int> no;
int size,flag=1;
void Createheap(int N){
Minheap.resize(N+1);
node n; Minheap[0]=n;
size=0;
}
void Insert(node n){
  int i=++size;
  for(;Minheap[i/2].weight>n.weight;i/=2)
  Minheap[i]=Minheap[i/2];
  Minheap[i]=n;
}
void ReadData(int N){
for(int i=1;i<=N;i++){
string str; int num;
cin>>str>>num;
no.push_back(num);
node n;
n.weight=num;
Insert(n);
}
}
node* Delete(){
node* n=new node();
n->l=Minheap[1].l;
n->r=Minheap[1].r;
n->weight=Minheap[1].weight;
node temp=Minheap[size--];
int parent,child;
for(parent=1;parent*2<=size;parent=child){
child=2*parent;
if(child!=size&&Minheap[child+1].weight<Minheap[child].weight)
++child;
if(temp.weight<=Minheap[child].weight) break;
else 
Minheap[parent]=Minheap[child];
}
Minheap[parent]=temp;
return n;
}
haffmantree huffman(int N){
    node T;
for(int i=1;i<N;i++){
node n;
n.l=Delete();
n.r=Delete();
n.weight=n.l->weight+n.r->weight;
Insert(n); 

T=*Delete();
return T;
}
int WPL(haffmantree T,int depth)

if(T.l==NULL&&T.r==NULL) return depth*(T.weight);
else return WPL(*(T.l),depth+1)+WPL(*(T.r),depth+1);
}
void judge(haffmantree* h,string code){
for(int i=0;i<code.length();i++){
if(code[i]=='0'){
if(h->l==NULL){
node* nod=new node();
h->l=nod;
}
else if(h->l->weight>0)
     flag=0;
h=h->l;
}
else if(code[i]=='1'){
if(h->r==NULL){
node* nod=new node();
h->r=nod;
}else if(h->r->weight>0)
     flag=0;
    h=h->r;
}
}
if(h->r==NULL&&h->l==NULL)
h->weight=1;
else flag=0;
}
int main(){
int N; cin>>N;
Createheap(N);
ReadData(N);
haffmantree T=huffman(N);
int wpl=WPL(T,0);
int M; cin>>M;
for(int i=1;i<=M;i++){
int len=0; haffmantree* h=new node();
for(int j=0;j<N;j++){
string str,code;
cin>>str>>code;
judge(h,code);
len+=no[j]*code.length();
}
if(len!=wpl) flag=0;
if(flag==1) cout<<"Yes"<<endl;
else cout<<"No"<<endl;
flag=1;
}
    return 0;



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值