HDU1698

12 篇文章 0 订阅
9 篇文章 0 订阅

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.
题意:区间更新&求区间和

#include<stdio.h>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
#define N 100005
using namespace std;
struct Tree{
    int l, r, sum, add;
}tree[N<<2];


//延迟更新 
void pushup(int root){//儿子把信息传递给父亲
    if(tree[root].l==tree[root].r)return ;
    tree[root].sum=tree[root<<1].sum+tree[root<<1|1].sum;   //<<1:*2; <<1|1:*2+1
    return ;
}
 void pushdown(int root){//父亲把自己的信息传给儿子
    if(tree[root].l==tree[root].r)return ;
    if(tree[root].add==-1)return ;
    tree[root<<1].add=tree[root<<1|1].add=tree[root].add;
    tree[root<<1].sum=(tree[root<<1].r-tree[root<<1].l+1)*tree[root].add; //长度*父亲.add
    tree[root<<1|1].sum=(tree[root<<1|1].r-tree[root<<1|1].l+1)*tree[root].add;
    tree[root].add=-1;
    return ;
}
//初始化 
void build(int l,int r,int root){
    tree[root].l=l;
    tree[root].r=r;
    tree[root].sum=0;
    tree[root].add=-1;
    if(l==r){//直到单个区间位置
        tree[root].sum=1;
        return;
    }
    int mid=(l+r)>>1;
    build(l,mid,root<<1);//左区间
    build(mid+1,r,root<<1|1); //右区间
    pushup(root);//把儿子的信息更新到父亲
    return;
}
//更新区间 
void update(int l,int r,int z,int root){
    if(l==tree[root].l&&tree[root].r==r){
        tree[root].sum=(tree[root].r-tree[root].l+1)*z;
        tree[root].add=z;//把要更新的内容保存下来,等到要用儿子时                                    再去更新
        return ;
    }
    pushdown(root);//用父亲的信息更新儿子
    int mid=tree[root].l+tree[root].r>>1;
    if(r<=mid)update(l,r,z,root<<1);
    else if(l>mid)update(l,r,z,root<<1|1);
    else {
        update(l,mid,z,root<<1);
        update(mid+1,r,z,root<<1|1);
    }
    pushup(root);//更新父亲
    return ;
}
//查找区间信息 
int query(int l,int r,int root){
    if(l==tree[root].l&&tree[root].r==r){
        return tree[root].sum;
    }
    pushdown(root);
    int mid=tree[root].l+tree[root].r>>1;
    if(r<=mid)return query(l,r,root<<1);
    else if(l>mid)return query(l,r,root<<1|1);
    else return query(l,mid,root<<1)+query(mid+1,r,root<<1|1);
}

int main()
{
    int t,n,m,cnt=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        build(1,n,1);
        while(m--)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            update(x,y,z,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cnt++,tree[1].sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值