POJ1961Period

6 篇文章 0 订阅
5 篇文章 0 订阅

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
题意:对一串给出的字符串,若从第一位开始到第i位的子串是有周期的,就输出i,以及循环了几次。这题和POJ2406的感觉很像。
next[i]表示前i-1个字符形成的子串,其前缀后缀最长公共元素的长度。
i%(i-next[i])==0 说明前i个字符形成的字符串是有周期的(因为i下标一般从0开始,所以i=3时是第四个字符,表示的是前三个字符形成的字符串的前后缀最长公共元素长度)
i/(i-next[i])表示有几个周期

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdlib>
using namespace std;
int next[1000005];
char s[1000005];
void getNext(char s[])
{
    int j, k;
    int len=strlen(s);
    j = 0; k = -1; next[0] = -1;
    while(j < len)
        if(k == -1 || s[j] == s[k])
        {
            next[++j] = ++k;
        }

        else
            k = next[k];

}
int main()
{
    int n,cnt=1;
    while(~scanf("%d",&n))
    {
        if(n==0) return 0;
        printf("Test case #%d\n",cnt++);
        scanf("%s",s);
        getNext(s);
        for(int i=2;i<=n;i++)
        {
            if(i%(i-next[i])==0&&next[i]!=0)//next[i]==0时i%(i-next[i])==0一定成立,但是此时i显然不符合要求
            printf("%d %d\n",i,i/(i-next[i]));

        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值