求二叉树的层次遍历

7 篇文章 0 订阅

求二叉树的层次遍历
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
已知一颗二叉树的前序遍历和中序遍历,求二叉树的层次遍历。

Input
输入数据有多组,输入T,代表有T组测试数据。每组数据有两个长度小于50的字符串,第一个字符串为前序遍历,第二个为中序遍历。

Output
每组输出这颗二叉树的层次遍历。

Sample Input
2
abc
bac
abdec
dbeac
Sample Output
abc
abcde
Hint
Source
fmh


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    int data;
    struct node *l,*r;
}bitnode;

bitnode *creat(int l,char qx[],char zx[])
{
    int i;
    bitnode *root;
    if(l==0) return NULL;
    root=(bitnode *)malloc(sizeof(bitnode));
    root->data=qx[0];
    for(i=0;i<l;i++)
    {
        if(zx[i]==qx[0])
            break;
    }
    root->l=creat(i,qx+1,zx);
    root->r=creat(l-i-1,qx+1+i,zx+1+i);
        return root;
}

void cc(bitnode *root)
{
    int in=0,out=0;
    bitnode *num[66];
    num[in++]=root;
    while(in>out)
    {
        if(num[out])
        {
            printf("%c",num[out]->data);
            num[in++]=num[out]->l;
            num[in++]=num[out]->r;
        }
        out++;
    }
}
int main()
{
    int t,l;
    char qx[55],zx[55];

    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%s %s",qx,zx);
            l=strlen(qx);
            bitnode *root;
            root=creat(l,qx,zx);
            cc(root);
            printf("\n");
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值