数据结构实验之二叉树四:(先序中序)还原二叉树

7 篇文章 0 订阅

数据结构实验之二叉树四:(先序中序)还原二叉树

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input
输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

Output
输出一个整数,即该二叉树的高度。

Sample Input

9
ABDFGHIEC
FDHGIBEAC

Sample Output
5

**Hint
Source
xam**


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    int data;
    struct node *l,*r;
};

struct node *creat(int n,char qx[],char zx[])
{
    int i;
    struct node *root;
    if(n==0) return NULL;
    root=(struct node*)malloc(sizeof(struct node));
    root->data=qx[0];
    for(i=0; i<n; i++)
    {
        if(zx[i]==qx[0])
            break;
    }
    root->l=creat(i,qx+1,zx);
    root->r=creat(n-i-1,qx+1+i,zx+i+1);
    return root;

}

int high(struct node *root)
{
    int hl,hr,max;
    if(root!=NULL)
    {
        hl=high(root->l);
        hr=high(root->r);
        if(hl>hr)
            max=hl;
        else
            max=hr;
        return max+1;
    }
    else
        return 0;
}
int main()
{
    int n,z;
    char qx[55],zx[55];

    while(~scanf("%d",&n))
    {
        struct node *root;
        scanf("%s%s",qx,zx);
        root=creat(n,qx,zx);
        z=high(root);
        printf("%d\n",z);
    }
    return 0;
}

求树的高度还有另一种方法

int high(bitnode *root)
{
    if(root==NULL) return 0;
    int lhigh=high(root->l)+1;
    int rhigh=high(root->r)+1;
    return lhigh>rhigh ? lhigh:rhigh;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值