数据结构实验之二叉树三:统计叶子数

7 篇文章 0 订阅

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output
输出二叉树的叶子结点个数。

Sample Input
abc,,de,g,,f,,,

Sample Output
3

**Hint
Source
xam**


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char a[110];//数组太小会超时
int p;
typedef struct bitnode
{
    int data;
    struct bitnode *lchild,*rchild;
} bitnode,*bitree;

bitree creat()
{
    bitree root;
    char c;
    c=a[p++];
    if(c==',')
        return NULL;
    else
    {
        root=(bitree)malloc(sizeof(bitnode));
        root->data=c;
        root->lchild=creat();
        root->rchild=creat();
    }
    return root;
}

int f(bitree root)
{

    if(root==NULL) return 0;
    if(root->lchild==NULL&&root->rchild==NULL) return 1;
    else
        return f(root->lchild)+f(root->rchild);
}

int main()
{
    bitree root;
    int q;
    while(~scanf("%s",a))
    {
         p=0;

        root=(bitree)malloc(sizeof(bitnode));
        root=creat();
        q=f(root);
        printf("%d\n",q);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值