最长公共子序列

题目描述:
Find a longest common subsequence of two strings.
输入:
First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.
输出:
For each case, output k – the length of a longest common subsequence in one line.
样例输入:
abcd
cxbydz
样例输出:
2

算法思想:

用dp[i][j]表示str1[i]和str2[j]处两字符串的最大公共子序列,则状态转移方程为:

若str1[i]==str2[j],则dp[i][j]=dp[i-1][j-1]+1;

若str1[i]!=str2[j],则dp[i][j]=max{dp[i-1][j],dp[i][j-1]};

其中dp[i][0]=0,dp[0][j]=0;

算法实现:

#include <stdio.h>
#include <string.h>
#define MAXN 101
int dp[MAXN][MAXN];
char str1[MAXN];
char str2[MAXN];
int main(){
    scanf("%s\n%s",str1+1,str2+1);
    int len1=strlen(str1+1);
    int len2=strlen(str2+1);
    int max=0;
    for(int i=0;i<=len1;i++){
        for(int j=0;j<=len2;j++){
            if(i==0||j==0){
                dp[i][j]=0;
                continue;
            }
            if(str1[i]==str2[j])
                dp[i][j]=dp[i-1][j-1]+1;
            else{
                dp[i][j]=dp[i-1][j];
                if(dp[i][j]<dp[i][j-1])
                    dp[i][j]=dp[i][j-1];
            }
            if(dp[i][j]>max)
                max=dp[i][j];
        }
    }
    printf("%d",max);
}

注意:

scanf("%s\n%s",str1+1,str2+1)表示输入的字符串下标从1开始;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值