链表之链表的归并

题目:
数据结构实验之链表四:有序链表的归并
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
Hint
不得使用数组!
Source

题目:

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node*next;
};
struct node *create(int n)
{
    struct node*head,*p,*tail;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    int i;
    for(i=1; i<=n; i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}
struct node *create2(struct node*h1,struct node*h2)
{
    struct node*p,*q,*tail;
    p=h1->next;
    q=h2->next;
    h1->next=NULL;
    h2->next=NULL;
    tail=h1;
    free(h2);
    while(p&&q)//这一个部分必须要写,不然没有办法循环
    {
        if(p->data<q->data)
        {
            tail->next=p;
            tail=p;
            p=p->next;
            tail->next=NULL;
        }//正序建表,然后指针往后指
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
        }
    }

    if(p==NULL)
    {
        tail->next=q;
    }
    else if(q==NULL)
    {
        tail->next=p;
    }//要注意这个地方不能丢
    return h1;
}
void print(struct node *h)
{
    struct node *q;
    q=h->next;
    while(q!=NULL)
    {
        if(q==h->next)
        {
            printf("%d",q->data);
        }
        else printf(" %d",q->data);
        q=q->next;
    }
    printf("\n");
}//输出函数
int main()
{
    int n,m;
    scanf("%d%d",&m,&n);
    struct node *h1,*h2,*h3;
    h1=create(m);
    h2=create(n);
    h3=create2(h1,h2);
    print(h3);
    return 0;
}

思路:
归并就是2个连在一起啊,借助其中一个的头指针,然后还需要2个指针分别指向2个序列,进行比较,最后还要考虑谁先变空

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值