链表之循环链表(约瑟夫问题)

题目:
约瑟夫问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description
n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。
Input
输入n和m值。
Output
输出胜利者的编号。
Sample Input
5 3
Sample Output
4
Hint
第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀
Source

解题代码:

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int name;
    struct node*next;
};
struct node*create(int n)
{
    struct node*head,*p,*tail;
    head=(struct node*)malloc(sizeof(struct node));
    head->name=1;
    head->next=NULL;
    tail=head;
    int i;
    for(i=2; i<=n; i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->name=i;//刚开始错在了这个地方,并没有把i放进去
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    tail->next=head;
    return head;
}
int main()
{
    int n,m;
    struct node*h,*p,*q;
    scanf("%d%d",&n,&m);
    int count=0;
    h=create(n);
    p=h;
    int num=0;
    while(p->next!=h)
    {
        p=p->next;
    }//为了从第一个出发
    while(count<n-1)
    {
        q=p->next;
        num++;
        if(num==m)
        {
            p->next=q->next;
            count++;//现在假设已经是第5个数了,P现在指向的是最后一个数,也就是说5的时候已经指向最后一个,所以得是N-1
            num=0;
        }
        else
        {
            p=q;
        }
    }
    printf("%d\n",p->name);
    return 0;
}

思路:设置一个跟随指针,跟着跑,Num的初始值都设为0,开始循环

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值