顺序表

数据结构上机测试1:顺序表的应用
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description

在长度为n(n<1000)的顺序表中可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只能有一个)。
Input

第一行输入表的长度n;
第二行依次输入顺序表初始存放的n个元素值。
Output

第一行输出完成多余元素删除以后顺序表的元素个数;
第二行依次输出完成删除后的顺序表元素。
Sample Input

12
5 2 5 3 3 4 2 5 7 5 4 3
Sample Output

5
5 2 3 4 7
Hint

用尽可能少的时间和辅助存储空间。
Source

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int n;
    struct node *head,*q,*p,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    int i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->next=NULL;
        scanf("%d",&p->data);
        tail->next=p;
        tail=p;
    }
    p=head->next;
    while(p)
    {
        q=p;
        while(q->next)
        {
            if(q->next->data!=p->data)//这样是q->next->data,可以直接跳过,如果是q->data相等的话,没办法跳过啊
            {
                q=q->next;
            }
            else
            {
                n--;
                q->next=q->next->next;
            }
        }
        p=p->next;
    }
    printf("%d\n",n);
    p=head->next;
    while(p)
    {
        if(p==head->next)
        {
            printf("%d",p->data);
        }
        else
        {
            printf(" %d",p->data);
        }
        p=p->next;
    }
    return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值