【杭电-oj】-5650-so easy(所有子集异或)

so easy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 649    Accepted Submission(s): 435


Problem Description
Given an array with
n
integers, assume  f(S)  as the result of executing xor operation among all the elements of set  S . e.g. if  S={1,2,3}  then  f(S)=0 .

your task is: calculate xor of all  f(s) , here  sS .
 

Input
This problem has multi test cases. First line contains a single integer  T(T20)  which represents the number of test cases.
For each test case, the first line contains a single integer number  n(1n1,000)  that represents the size of the given set. then the following line consists of  n different integer numbers indicate elements( 109 ) of the given set.
 

Output
For each test case, print a single integer as the answer.
 

Sample Input
   
   
1 3 1 2 3
 

Sample Output
   
   
0 In the sample,$S = \{1, 2, 3\}$, subsets of $S$ are: $\varnothing$, {1}, {2}, {3}, {1, 2}, {1, 3}, {2, 3}, {1, 2, 3}
 
n=1时,原样输出。n>1时,每个数出现的次数都是偶数,异或后都为零。
注:异或满足交换律和结合律

#include <cstdio>  
int main()  
{  
    int t;  
    int n;  
    int num[1111];  
    int ans;  
    scanf ("%d",&t);  
    while (t--)  
    {  
        scanf ("%d",&n);  
        for (int i = 1 ; i <= n ; i++)  
            scanf ("%d",&num[i]);  
        if (n == 1)  
            printf ("%d\n",num[1]);  
        else  
            printf ("0\n");  
    }  
    return 0;  
}  







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值