【杭电-oj】-5499-SDOI(结构体)

SDOI

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 895    Accepted Submission(s): 358


Problem Description
The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI.  n(n100)  people comes to the Select and there is  m(m50)  people who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is  300 .

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is  x .(it is promised that not all person in one round is 0,in another way, x>0 ). So for this round,everyone's final mark equals to his/her original  mark(300/x) .

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as  0.3round1s  final mark +  0.7round2s  final mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.
2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.
 

Input
There is an integer  T(T100)  in the first line for the number of testcases and followed  T  testcases.

For each testcase, there are two integers  n  and  m  in the first line (nm) , standing for the number of people take part in SDOI and the allowance of the team.Followed with  n  lines,each line is an information of a person. Name(A string with length less than  20 ,only contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than  300 ) separated with a space.

 

Output
For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed  m  lines,every line is the name of the team with their Ultimate mark decreasing.
 

Sample Input
  
  
2 10 8 dxy male 230 225 davidwang male 218 235 evensgn male 150 175 tpkuangmo female 34 21 guncuye male 5 15 faebdc male 245 250 lavender female 220 216 qmqmqm male 250 245 davidlee male 240 160 dxymeizi female 205 190 2 1 dxy male 300 300 dxymeizi female 0 0
 

Sample Output
  
  
The member list of Shandong team is as follows: faebdc qmqmqm davidwang dxy lavender dxymeizi davidlee evensgn The member list of Shandong team is as follows: dxymeizi Hint For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2. The Final of The Ultimate score is as followed faebdc 298.20 qmqmqm 295.80 davidwang 275.88 dxy 271.80 lavender 260.64 dxymeizi 233.40 davidlee 220.80 evensgn 201.00 tpkuangmo 29.88 guncuye 14.40 For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.
 
英文太长,看都不想看,题看错了,wa了,也不行检查,这样会死的啊!!!
题意:n个人找m个参加比赛,有女生有“优惠”。
1,判断有无女生,没有直接输出。有再做处理:先输出m-1项,判断里面有无女生,有直接输出m项。无,输出女生中最高的。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct people
{
	char name[110];
	char xb[10];
	double a,b;
	double mark;							//注意有除法,double型 
}a[110],b[110];
bool cmp(people a,people b)
{
	return a.mark>b.mark;
}
int main()
{
	int t,x,y,z,ant;
	scanf("%d",&t);
	while(t--)
	{
		x=0,y=0,ant=0;						//x,y 用于两次判断有无女生的变量 
		double max1=0,max2=0;				//根据题意找出第一,第二的最高成绩 
		int n,m;
		scanf("%d %d",&n,&m);
		for(int i=0;i<n;i++)
		{
			scanf("%s %s %lf %lf",a[i].name,a[i].xb,&a[i].a,&a[i].b);
			max1=max(max1,a[i].a);
			max2=max(max2,a[i].b);
		}
		max1=300.0/max1;
		max2=300.0/max2;
		for(int i=0;i<n;i++)
		{
			a[i].mark=0.3*a[i].a*max1+0.7*a[i].b*max2;
			int A=strcmp(a[i].xb,"female");
			if(A==0)							//第一次判断又无女生,有为1 
				x=1;
		}
		sort(a,a+n,cmp);
		if(x==0)								//没有女生直接输出 
		{
			printf("The member list of Shandong team is as follows:\n");
			for(int i=0;i<m;i++)
				printf("%s\n",a[i].name);
		} 
		else
		{
			printf("The member list of Shandong team is as follows:\n");
			for(int i=0;i<m-1;i++)
			{
				printf("%s\n",a[i].name);				//有女生,先输出前m-1个 
				int A=strcmp(a[i].xb,"female");
				if(A==0)								 
					y=1;
			}
			if(y!=0)
				printf("%s\n",a[m-1].name);			//判断前m-1个有无女生,有直接输出第m个
			else
			{
				for(int i=0;i<n;i++)
				{
					int A=strcmp(a[i].xb,"female");		
					if(A==0)						//前m-1个没有女生要输出成绩最高的女生,把所有女生成绩重新存入b数组 
					{
						b[ant].mark=a[i].mark;
						ant++;
					}
				}
				sort(b,b+ant,cmp);					//找到女生成绩最高的 
				for(int i=0;i<n;i++)
				{
					if(b[0].mark==a[i].mark)		
					{
						z=i;
						break;					//找到女生是多少,然后输出名字 
					}
				}
				printf("%s\n",a[z].name);
			}
		} 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值