【HDU】-1789-Doing Homework again(贪心,好)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11360    Accepted Submission(s): 6678


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5


这道题真的不简单,想得倒不会用代码来写,还是做题少。看了学姐的代码,感觉好明白。

师父让我用并查集可是我不会啊!!!

题解:把分数从大到小排序,分数大的看看当天可不可以完成,不可以向前推一天,那么那一天就被占用,标记出来。

以此类,推依次判断

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct people
{
	int day,mak;
}a[1010];
bool cmp(people x,people y)
{
	return x.mak>y.mak;
}
int main()
{
	int t;
	int mark[10010];
	scanf("%d",&t);
	while(t--)
	{
		int n,ant=0;
		int flag=0;
		memset(mark,0,sizeof(mark));		//初始化为0 
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i].day);	
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i].mak);
		sort(a+1,a+1+n,cmp);				//把分数从大到小排序 
		for(int i=1;i<=n;i++)
		{
			flag=0;							//没完成flag=0,完成变成1 
			for(int j=a[i].day;j>=1;j--)	//当天没有任务当天做,有向前找 
			{
				if(mark[j]==0)				// 没有作业安排mark=0 
				{
					mark[j]=1;				//安排作业mark变为1 
					flag=1;					//完成,flag=1 
					break;
				}
			}
			if(!flag)						//flag=0,扣分 
				ant+=a[i].mak;
		}
		printf("%d\n",ant);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值