【POJ】-1979-Red and Black(DFS)

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 30654 Accepted: 16685

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题解:从起点出发(先标记为1,因为走过),向上下左右找找到可以去的点标记为1,ans+1,。再从这个点出发上下左右找可以去的点。找点标记,类似继续。找不到(都是墙),回溯上一个判断是否还有可以去的,可以继续,不可以再回溯上一个。

#include<cstdio>
#include<cstring>
char a[22][22];
int vis[22][22];				//用来标记走过的点,标记为 1 
int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1};	
int n,m,x,y,ans;
void dfs(int xx,int yy)
{
	for(int i=0;i<4;i++)			//上下左右走,满足下一个位置是点且没有走过(没有标记),也没有走出范围就走他,并把它标记 
	{
		if(a[xx+dx[i]][yy+dy[i]]=='.'&&vis[xx+dx[i]][yy+dy[i]]==0&&(xx+dx[i])>0&&(xx+dx[i])<=m&&(yy+dy[i])>0&&(yy+dy[i])<=n)
		{
			vis[xx+dx[i]][yy+dy[i]]=1;
			ans++;						//可以走,加 1 
			dfs(xx+dx[i],yy+dy[i]);		//以这个点为起点,像上一个那样继续找	
		}
	}
}
int main()
{
	while(~scanf("%d %d",&n,&m)&&m&&n)
	{
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=m;i++)
		{
			getchar();
			for(int j=1;j<=n;j++)
			{
				scanf("%c",&a[i][j]);
				if(a[i][j]=='@')
				{
					x=i;
					y=j;
					vis[i][j]=1;		//记录下当前的位置 
				}
			}
		}
		ans=1;					//最开始的位置也是一个 
		dfs(x,y);
		printf("%d\n",ans);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值