【POJ】-3620-Avoid The Lakes(DFS)

Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7877 Accepted: 4148

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

题意:n*m的地,有k块是湿的,求湿的相连的面积最多有多少块。

题解:把所有干的都看为1,不可走。湿的看为0;不全部相连的每块湿地都有一个自己相连的块数,求出他们中的最大值即可。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std; 
int n,m,k,ans;
int a[110][110];
int dx[4]={-1,1,0,0};				//相邻的湿地,也可看为是不是可以上下左右走 
int dy[4]={0,0,-1,1};
int vis[110][110];
void dfs(int xx,int yy)
{
	for(int i=0;i<4;i++)
	{
		if(a[xx+dx[i]][yy+dy[i]]==0&&vis[xx+dx[i]][yy+dy[i]]==0&&(xx+dx[i])>0&&(xx+dx[i])<=n&&(yy+dy[i])>0&&(yy+dy[i])<=m)
		{
			vis[xx+dx[i]][yy+dy[i]]=1;			//a[i][j]是0(湿地)且没有走过(vis=0)且不会超出边界就走这一块,并标记(vis=1) 
			ans++;						 		//相连的又多了一块,ans++ 
			dfs(xx+dx[i],yy+dy[i]);				//以此为开始,继续找 
		}
	}
}
int main()
{
	while(~scanf("%d %d %d",&n,&m,&k))
	{
		int t1,t2,maxx=0;	
		memset(a,1,sizeof(a));				//全部初始化为1,看为干的地。不用找,看为不可走 
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=k;i++)
		{
			scanf("%d %d",&t1,&t2);
			a[t1][t2]=0;					//湿的地重新定为0,可走 
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)			
			{
				if(a[i][j]==0)				//要对所有的湿地进行排查 
				{	
					ans=1;					//此刻的湿地也要记录,ans=1 
					vis[i][j]=1;			//走过了,vis为 1 
					dfs(i,j);
					maxx=max(maxx,ans);		//每块不相连的湿地,ans都有一个值,找到最大的 
				}	
			}	
		}
		printf("%d\n",maxx);	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值